android运行测试遇到minsdk (API23) > devicesdk (API22)解决

重装了系统,安装了新环境后重新安装了android studio写了个小东西,跑测试的时候出现了报错:minsdk (API23) > devicesdk (API22)

这个错误是因为我虚拟机只建了一个华为荣耀V9的虚拟机,版本api差了一个版本提示的错误。

解决这个错误两个方法:

一、如果一定要api23的sdk,那么就新建一个虚拟机adnroid版本要是6.0以上的,测试的时候选这个虚拟机就行了。

二、就是修改项目的sdk版本,build.gradle文件里android下defaultConfig下的minSdkVersion的值改成22就可以了。


Tags 安卓

留言(0)

评论